summaryrefslogtreecommitdiff
path: root/dev-python/ijson/ijson-3.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ijson/ijson-3.2.3.ebuild')
-rw-r--r--dev-python/ijson/ijson-3.2.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/ijson/ijson-3.2.3.ebuild b/dev-python/ijson/ijson-3.2.3.ebuild
deleted file mode 100644
index cec2473254c3..000000000000
--- a/dev-python/ijson/ijson-3.2.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Iterative JSON parser with a Pythonic interface"
-HOMEPAGE="
- https://github.com/ICRAR/ijson/
- https://pypi.org/project/ijson/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-
-DEPEND="
- dev-libs/yajl
-"
-RDEPEND="
- ${DEPEND}
-"
-
-distutils_enable_tests pytest
-
-export IJSON_BUILD_YAJL2C=1
-
-python_test() {
- rm -rf ijson || die
- epytest
-}