summaryrefslogtreecommitdiff
path: root/dev-python/ijson/ijson-3.2.0_p0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ijson/ijson-3.2.0_p0.ebuild')
-rw-r--r--dev-python/ijson/ijson-3.2.0_p0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/ijson/ijson-3.2.0_p0.ebuild b/dev-python/ijson/ijson-3.2.0_p0.ebuild
new file mode 100644
index 000000000000..418b4c582e7b
--- /dev/null
+++ b/dev-python/ijson/ijson-3.2.0_p0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${P//_p/.post}"
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson/
+ https://pypi.org/project/ijson/
+"
+SRC_URI="
+ https://github.com/ICRAR/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/yajl
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest