summaryrefslogtreecommitdiff
path: root/dev-python/idna-ssl/idna-ssl-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/idna-ssl/idna-ssl-1.0.1.ebuild')
-rw-r--r--dev-python/idna-ssl/idna-ssl-1.0.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/idna-ssl/idna-ssl-1.0.1.ebuild b/dev-python/idna-ssl/idna-ssl-1.0.1.ebuild
new file mode 100644
index 000000000000..bb91e721918b
--- /dev/null
+++ b/dev-python/idna-ssl/idna-ssl-1.0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Patch ssl.match_hostname for Unicode(idna) domains support"
+HOMEPAGE="https://github.com/aio-libs/idna-ssl https://pypi.python.org/pypi/idna_ssl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/idna[${PYTHON_USEDEP}]"