summaryrefslogtreecommitdiff
path: root/dev-python/icalendar/icalendar-5.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/icalendar/icalendar-5.0.1.ebuild')
-rw-r--r--dev-python/icalendar/icalendar-5.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/icalendar/icalendar-5.0.1.ebuild b/dev-python/icalendar/icalendar-5.0.1.ebuild
new file mode 100644
index 000000000000..4b300aa3103d
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}