summaryrefslogtreecommitdiff
path: root/dev-python/icalendar/icalendar-4.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/icalendar/icalendar-4.0.7.ebuild')
-rw-r--r--dev-python/icalendar/icalendar-4.0.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/icalendar/icalendar-4.0.7.ebuild b/dev-python/icalendar/icalendar-4.0.7.ebuild
new file mode 100644
index 000000000000..4b472fff1bc1
--- /dev/null
+++ b/dev-python/icalendar/icalendar-4.0.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="https://github.com/collective/icalendar"
+SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}