summaryrefslogtreecommitdiff
path: root/dev-python/hvac/hvac-1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hvac/hvac-1.0.2.ebuild')
-rw-r--r--dev-python/hvac/hvac-1.0.2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/hvac/hvac-1.0.2.ebuild b/dev-python/hvac/hvac-1.0.2.ebuild
deleted file mode 100644
index b8228fb1bc71..000000000000
--- a/dev-python/hvac/hvac-1.0.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="hashicorp vault client in python"
-HOMEPAGE="
- https://github.com/hvac/hvac/
- https://pypi.org/project/hvac/
-"
-SRC_URI="https://github.com/hvac/hvac/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-RDEPEND="
- >=dev-python/pyhcl-0.4.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/jwcrypto[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/semantic_version[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # ldap_test is not packaged.
- tests/integration_tests/api/auth_methods/test_ldap.py
- # https://github.com/lepture/authlib is not packaged.
- tests/integration_tests/api/auth_methods/test_oidc.py
-)