summaryrefslogtreecommitdiff
path: root/dev-python/humanize
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest2
-rw-r--r--dev-python/humanize/humanize-4.4.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 4cd138917641..c7d1fe424415 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,3 +1,5 @@
DIST humanize-4.3.0.tar.gz 78035 BLAKE2B 03cea639879165453becc41f62e7b6e34a62ac3a74c37141e0c3f7e9d855b2727710ab5ac231a3829d03c413b297449dccbfc8b804b3f5ddcd402dd813adbf57 SHA512 b8713fa9ec2c2210f93e06436a5bef390937b85ccd0bc95520e53d5c0f49354b94a7957ef50dd9e391d8377d1faf43003c47028b19cef42885fd083cbda1ac46
+DIST humanize-4.4.0.tar.gz 78519 BLAKE2B f61b654e201995479ace22b5aac106b08304ed9212cf5c6c7f87731d861c42c5e0243f7bb0b7f2c29b870421fa81fba0c36e4ead90ff90f207bc984286ac119a SHA512 bbbd386d9af82d9db0f2edc4653928654203c4239419232abfc15c51ccd865b355366549c46651e1291d4222ca8b2a297ffc0fce3cc32be4ae2f904ae308a8e4
EBUILD humanize-4.3.0.ebuild 586 BLAKE2B f89d881fd19e60a8eb9c2ffd5d53e8b0e6ac16672c16f441b2bf8e776b81b7a20218af77eb61fb4a1d9ae744906e361fd953da37b7e94542fd5e2e0c3bd329e7 SHA512 3f7f0f0239a899ab1445277b7944da5763d5585e287ccad072a0aa6b86d8bc2c5e0557c255f7d8e29d630ce681b2c95985dfdbbb72127a886df1a6cd79a85e1c
+EBUILD humanize-4.4.0.ebuild 588 BLAKE2B 7ccbcefd9b985a2eb85773993629bec0fdab43f09a9f092c67a520b123639a8272f01296153b0ef38a9ae498032807af089e4536b2482adbc033a5a4468f6a97 SHA512 53444dd98c6898caf5158cc5e5a55355ba7269cf7e1d130a5788ae246c7f0e1af06e53d2c99b094985583e2f472d28027d724a47bfb0c57f18ee1e2daa0fb5f7
MISC metadata.xml 506 BLAKE2B c00c304481f8bd5d2309a1fa72a19bd8405d2f8d55e68a9e688435dec5410db728537362d6fc090f448738fa462ad62d03cfdb82fda8702b91aced4ecd6c05d5 SHA512 71905cfb331f60723b2b3dc02b1a5cbc2712ea9a411692d8ce12e62ea90a4ebef41bb4806b90f9bc0706d8dfb6a3ebb69d23ef16f0177eaddcfbdf07612d8614
diff --git a/dev-python/humanize/humanize-4.4.0.ebuild b/dev-python/humanize/humanize-4.4.0.ebuild
new file mode 100644
index 000000000000..b471878fc311
--- /dev/null
+++ b/dev-python/humanize/humanize-4.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest