summaryrefslogtreecommitdiff
path: root/dev-python/humanize/humanize-4.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanize/humanize-4.9.0.ebuild')
-rw-r--r--dev-python/humanize/humanize-4.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/humanize/humanize-4.9.0.ebuild b/dev-python/humanize/humanize-4.9.0.ebuild
new file mode 100644
index 000000000000..681e01638c1b
--- /dev/null
+++ b/dev-python/humanize/humanize-4.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest