summaryrefslogtreecommitdiff
path: root/dev-python/humanize/humanize-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanize/humanize-3.0.0.ebuild')
-rw-r--r--dev-python/humanize/humanize-3.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/humanize/humanize-3.0.0.ebuild b/dev-python/humanize/humanize-3.0.0.ebuild
new file mode 100644
index 000000000000..94f1f6012cd1
--- /dev/null
+++ b/dev-python/humanize/humanize-3.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # The package uses pkg_resources to determine its version
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}