summaryrefslogtreecommitdiff
path: root/dev-python/httpstat/httpstat-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpstat/httpstat-1.2.1.ebuild')
-rw-r--r--dev-python/httpstat/httpstat-1.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/httpstat/httpstat-1.2.1.ebuild b/dev-python/httpstat/httpstat-1.2.1.ebuild
new file mode 100644
index 000000000000..2b9302f689b2
--- /dev/null
+++ b/dev-python/httpstat/httpstat-1.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
+HOMEPAGE="https://github.com/reorx/httpstat"
+SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="net-misc/curl:*"
+
+# Requires access to google.com and http2.akamai.com
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
+
+python_test() {
+ ./httpstat_test.sh || die
+}