summaryrefslogtreecommitdiff
path: root/dev-python/httpcore/httpcore-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpcore/httpcore-1.0.3.ebuild')
-rw-r--r--dev-python/httpcore/httpcore-1.0.3.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/httpcore/httpcore-1.0.3.ebuild b/dev-python/httpcore/httpcore-1.0.3.ebuild
deleted file mode 100644
index 24a34134c031..000000000000
--- a/dev-python/httpcore/httpcore-1.0.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="A minimal low-level HTTP client"
-HOMEPAGE="
- https://www.encode.io/httpcore/
- https://github.com/encode/httpcore/
- https://pypi.org/project/httpcore/
-"
-SRC_URI="
- https://github.com/encode/httpcore/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- <dev-python/anyio-5[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- <dev-python/h11-0.15[${PYTHON_USEDEP}]
- <dev-python/h2-5[${PYTHON_USEDEP}]
- =dev-python/sniffio-1*[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-trio[${PYTHON_USEDEP}]
- dev-python/socksio[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-pkg_postinst() {
- optfeature "SOCKS support" dev-python/socksio
-}