summaryrefslogtreecommitdiff
path: root/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch')
-rw-r--r--dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch b/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
deleted file mode 100644
index 5d626768bd27..000000000000
--- a/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -dupr a/httpbin/core.py b/httpbin/core.py
---- a/httpbin/core.py 2018-05-08 13:41:03.000000000 +0200
-+++ b/httpbin/core.py 2019-11-22 15:07:27.516500217 +0100
-@@ -21,7 +21,6 @@ from werkzeug.datastructures import WWWA
- from werkzeug.http import http_date
- from werkzeug.wrappers import BaseResponse
- from werkzeug.http import parse_authorization_header
--from raven.contrib.flask import Sentry
-
- from . import filters
- from .helpers import get_headers, status_code, get_dict, get_request_range, check_basic_auth, check_digest_auth, \
-@@ -58,6 +57,7 @@ app.debug = bool(os.environ.get('DEBUG')
-
- # Send app errors to Sentry.
- if 'SENTRY_DSN' in os.environ:
-+ from raven.contrib.flask import Sentry
- sentry = Sentry(app, dsn=os.environ['SENTRY_DSN'])
-
- # Set up Bugsnag exception tracking, if desired. To use Bugsnag, install the
-diff --git a/setup.py b/setup.py
-index 7f9956b..3cab2ae 100644
---- a/setup.py
-+++ b/setup.py
-@@ -35,6 +35,6 @@ setup(
- include_package_data = True, # include files listed in MANIFEST.in
- install_requires=[
- 'Flask', 'MarkupSafe', 'decorator', 'itsdangerous', 'six', 'brotlipy',
-- 'raven[flask]', 'werkzeug>=0.14.1'
-+ 'werkzeug>=0.14.1'
- ],
- )