summaryrefslogtreecommitdiff
path: root/dev-python/html5lib/html5lib-1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/html5lib/html5lib-1.1.ebuild')
-rw-r--r--dev-python/html5lib/html5lib-1.1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/html5lib/html5lib-1.1.ebuild b/dev-python/html5lib/html5lib-1.1.ebuild
index 3dc621cb73c5..3fddc1546717 100644
--- a/dev-python/html5lib/html5lib-1.1.ebuild
+++ b/dev-python/html5lib/html5lib-1.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
PYTHON_REQ_USE="xml(+)"
inherit distutils-r1
@@ -15,14 +15,15 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT+=" !test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest6.patch
+)
RDEPEND=">=dev-python/six-1.9[${PYTHON_USEDEP}]
dev-python/webencodings[${PYTHON_USEDEP}]"
BDEPEND="
test? (
- ${RDEPEND}
dev-python/pytest-expect[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)"