summaryrefslogtreecommitdiff
path: root/dev-python/h5py
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/Manifest2
-rw-r--r--dev-python/h5py/h5py-3.11.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
index a5c814b9f137..b9253e725b49 100644
--- a/dev-python/h5py/Manifest
+++ b/dev-python/h5py/Manifest
@@ -1,4 +1,6 @@
DIST h5py-3.10.0-cython3.patch.xz 3868 BLAKE2B 3c0d952bdca5307ebf0bf878c26b94d0593bb89ac538a51017fb94e1e488bffc1583dcf4e713005b87d1b5e20d7b73043b24d65404faf60fb69515e598ca2133 SHA512 a0a0e3d1a9bccad1c89aa7efe3ba1e080eb70cae1f42f8de1021c212817970eaaa7070131e8e39859eea3c18d6c1243a17e7f53f2179f34ff6c406b315bab8fa
DIST h5py-3.10.0.tar.gz 403716 BLAKE2B a8e4351a15aee5fe9d23f9c5f9b6ff44e688a391ba17e27338675bde60415c73e3cd97a4a0c05490df849f649d626450d3dbecc9ae6ea3d24d784a0a4aaa1850 SHA512 840d7f2b9b9d5e22e8edae21c84884abec64acdd6c36437a4921ce9dc1b343c55f66f72b699146d71fe55688f6f948787b62335a24906288e9565b2b19b24b01
+DIST h5py-3.11.0.tar.gz 406519 BLAKE2B a5568c96290eee1f6da965174b6fa398f94e2e1825ec4ec50efd856b37ccf2bf634cfeb32101c7c53712fe9c68b0617774e9339a3f0d9373d3df24e6763a20cf SHA512 05d99093d5e7c280779b4167bd3594488dfc348b800da95c2275ddc8d77b4208fd1353942bf8863c4859d0208e8aa8bf84e628b3c5942eb947ecdcf0a7d19e88
EBUILD h5py-3.10.0-r1.ebuild 1429 BLAKE2B 25a02fbacf97d95e965119944d9d11845d46ea34710733993a0c78a2ad68dbc11a5db50de72cdd5767a5fe96113241b8fef78c50263d5fea66de2b07f6923f8e SHA512 ffd927524a5dd51ef273023b591ff334a07dd95c9762110c45fcb0918fb569b1417c661c33edfbaecdccb72779fc196a6d325eb9f2895fcdd91a05e8bbcc9b1f
+EBUILD h5py-3.11.0.ebuild 1377 BLAKE2B cd595495a67b31e5eee53eea23e8fec0c0ad144434d82bd97579d1554347254a826e99b7de408857f7dfb214a02f799187f2e9456abc95910698e965cdd5629f SHA512 7f8fa265504c931a742e24ed731c739571c8e48f0442b8f779711540a4aff9dad8689f5c790e2e779ac87105e8376601dde3aeeef39df0310607430b540547c3
MISC metadata.xml 1069 BLAKE2B 0f3ef8e7af7f4bb493824427a238588c019c04c28fe8a4b9c0b9af1c986158eb3dae3b7d7937713cc4c87374ef80686603ccdbae2baff5b1150d814ab108d973 SHA512 47a6074e383cc922234ebb9f67aaa5863421eaeb2003444587bb8499b3bf845da93ac8d8d267717bea01300691df10f67c9389248fbe228afe07c17fba3a64f3
diff --git a/dev-python/h5py/h5py-3.11.0.ebuild b/dev-python/h5py/h5py-3.11.0.ebuild
new file mode 100644
index 000000000000..0cebc6b7bda9
--- /dev/null
+++ b/dev-python/h5py/h5py-3.11.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="
+ https://www.h5py.org/
+ https://github.com/h5py/h5py/
+ https://pypi.org/project/h5py/
+"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-3.10.0-cython3.patch.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+DEPEND="
+ >=sci-libs/hdf5-1.10.4:=[hl(+)]
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/numpy-1.17.3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ >=dev-python/cython-0.29.31[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/QtPy[testlib,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+python_prepare_all() {
+ # avoid pytest-mpi dep, we do not use mpi anyway
+ sed -i -e 's:pytest-mpi::' pytest.ini || die
+ distutils-r1_python_prepare_all
+
+ export H5PY_SETUP_REQUIRES=0
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest -m "not mpi"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}