summaryrefslogtreecommitdiff
path: root/dev-python/grpcio/grpcio-1.16.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/grpcio/grpcio-1.16.0.ebuild')
-rw-r--r--dev-python/grpcio/grpcio-1.16.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/grpcio/grpcio-1.16.0.ebuild b/dev-python/grpcio/grpcio-1.16.0.ebuild
deleted file mode 100644
index 312146bd5e1a..000000000000
--- a/dev-python/grpcio/grpcio-1.16.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1
-
-DESCRIPTION="High-performance RPC framework (python libraries)"
-HOMEPAGE="https://grpc.io"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- net-dns/c-ares:=
- !<net-libs/grpc-1.16.0[python]
- sys-libs/zlib:=
- virtual/python-enum34[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-python_compile() {
- export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
- export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
- export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
- export GRPC_PYTHON_BUILD_WITH_CYTHON=1
- distutils-r1_python_compile
-}