summaryrefslogtreecommitdiff
path: root/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild')
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
index 540f323b3815..e5b88706d9e3 100644
--- a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
+++ b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
GCONF_DEBUG="no"
PYTHON_COMPAT=( python2_7 )
-inherit versionator eutils gnome2 python-any-r1
+inherit versionator eutils gnome2 python-r1
# This ebuild does nothing -- we just want to get the pkgconfig file installed
@@ -16,6 +16,7 @@ PVP="$(get_version_component_range 1-2)"
SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="LGPL-2.1"
SLOT="2"
RESTRICT="${RESTRICT} test"
@@ -23,10 +24,9 @@ RESTRICT="${RESTRICT} test"
# From the gnome-python eclass
RDEPEND=">=x11-libs/gtk+-2.6:2
>=dev-libs/glib-2.6:2
- $(python_gen_any_dep '
- >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
- >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
- ')
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
!<dev-python/gnome-python-2.22.1"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -35,6 +35,10 @@ KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-li
S="${WORKDIR}/${MY_PN}-${PV}"
+src_prepare() {
+ python_setup
+}
+
src_configure() {
gnome2_src_configure \
--disable-allbindings