summaryrefslogtreecommitdiff
path: root/dev-python/glooey
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/glooey')
-rw-r--r--dev-python/glooey/Manifest3
-rw-r--r--dev-python/glooey/glooey-0.3.1.ebuild33
-rw-r--r--dev-python/glooey/metadata.xml20
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/glooey/Manifest b/dev-python/glooey/Manifest
new file mode 100644
index 000000000000..5b696e966074
--- /dev/null
+++ b/dev-python/glooey/Manifest
@@ -0,0 +1,3 @@
+DIST glooey-0.3.1.tar.gz 19110562 BLAKE2B 252621789def523e3f8535ff6d72d3b5e71664cc5a0b2b4440b64be8170c08f275709c1771d2ab154349da643a521dae352e711b7f0a705f0e6eaeb1bd842932 SHA512 c804125bc9ccd9f2b44cc5fcf5a0c7353402aa8587641fc75870bf0c2474c449936dd41ddc641050009f32dbaef4e05fecd4c60c477c0c89512a02028f957c65
+EBUILD glooey-0.3.1.ebuild 677 BLAKE2B f6059201f2d3567475cbbe320f72b2a6fd66b5b0fa56605343d6a783a2761b8ff5c203a7beaed486d4a01338900d7f2693d68c567acb2e6dcb0ff610b03315a8 SHA512 9621aa917773a18f3c42e9cda20b3024192ca68abfeef5ab00d71d87b4cb8bc897474d7096d4eb3d1e2f321b1bffab77207e17eeef9f384593a0f8e229ebcc56
+MISC metadata.xml 1114 BLAKE2B b330daced3638afc8df0d8d7d5074a7228fa60bb7c4095c0b09e91992fef0186e1269cdc0ba4d59f1ac00168ed8947bbf11baaaf9b6a2aa342bddf7bfb9f2e1b SHA512 aa3103d9a2a6c536faf89e3bc8704735c6699c22db038c9077d2b7dd0ca5f31de6264b06d1fe3e2633cb3972e5acee76ed9dfa08115231bc29d6a0c6ce0b811f
diff --git a/dev-python/glooey/glooey-0.3.1.ebuild b/dev-python/glooey/glooey-0.3.1.ebuild
new file mode 100644
index 000000000000..f6ee41b5d1ce
--- /dev/null
+++ b/dev-python/glooey/glooey-0.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..9})
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="An object-oriented GUI library for pyglet"
+HOMEPAGE="https://glooey.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ dev-python/autoprop[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/vecrec[${PYTHON_USEDEP}]
+"
+
+BDEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
diff --git a/dev-python/glooey/metadata.xml b/dev-python/glooey/metadata.xml
new file mode 100644
index 000000000000..28c0e77535aa
--- /dev/null
+++ b/dev-python/glooey/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Every game needs a user interface that matches its look and feel. The purpose of glooey is to help you make
+ such an interface. Towards this end, glooey provides 7 powerful placement widgets, a label widget, an image
+ widget, 3 different button widgets, a text entry widget, a variety of scroll boxes and bars, 4 different dialog
+ box widgets, and a variety of other miscellaneous widgets. The appearance of any widget can be trivially
+ customized, and glooey comes with built-in fantasy, puzzle, and 8-bit themes to prove it (and to help you hit
+ the ground running if your game fits one of those genres).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kxgames/glooey</remote-id>
+ <remote-id type="pypi">glooey</remote-id>
+ </upstream>
+</pkgmetadata>