summaryrefslogtreecommitdiff
path: root/dev-python/glob2/glob2-0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/glob2/glob2-0.7.ebuild')
-rw-r--r--dev-python/glob2/glob2-0.7.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/glob2/glob2-0.7.ebuild b/dev-python/glob2/glob2-0.7.ebuild
new file mode 100644
index 000000000000..11eff6e0a41d
--- /dev/null
+++ b/dev-python/glob2/glob2-0.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Extended version of Python's builtin glob module"
+HOMEPAGE="https://pypi.org/project/glob2/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}