summaryrefslogtreecommitdiff
path: root/dev-python/gfloat/gfloat-0.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gfloat/gfloat-0.0.5.ebuild')
-rw-r--r--dev-python/gfloat/gfloat-0.0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/gfloat/gfloat-0.0.5.ebuild b/dev-python/gfloat/gfloat-0.0.5.ebuild
new file mode 100644
index 000000000000..a3db6988220f
--- /dev/null
+++ b/dev-python/gfloat/gfloat-0.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Generic floating-point types in Python"
+HOMEPAGE="
+ https://github.com/graphcore-research/gfloat/
+ https://pypi.org/project/gfloat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ml-dtypes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest