summaryrefslogtreecommitdiff
path: root/dev-python/gentoo-common/gentoo-common-0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gentoo-common/gentoo-common-0.ebuild')
-rw-r--r--dev-python/gentoo-common/gentoo-common-0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/gentoo-common/gentoo-common-0.ebuild b/dev-python/gentoo-common/gentoo-common-0.ebuild
new file mode 100644
index 000000000000..58e23e58f72d
--- /dev/null
+++ b/dev-python/gentoo-common/gentoo-common-0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Common files shared by Python implementations in Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
+S=${WORKDIR}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+src_install() {
+ insinto /usr/lib/python
+ # https://peps.python.org/pep-0668/
+ newins - EXTERNALLY-MANAGED <<-EOF
+ [externally-managed]
+ Error=
+ The system-wide Python installation in Gentoo should be maintained
+ using the system package manager (e.g. emerge).
+
+ If the package in question is not packaged for Gentoo, please
+ consider installing it inside a virtual environment, e.g.:
+
+ python -m venv /path/to/venv
+ . /path/to/venv/bin/activate
+ pip install mypackage
+ EOF
+}