summaryrefslogtreecommitdiff
path: root/dev-python/future/future-0.16.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/future/future-0.16.0-r1.ebuild')
-rw-r--r--dev-python/future/future-0.16.0-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/future/future-0.16.0-r1.ebuild b/dev-python/future/future-0.16.0-r1.ebuild
deleted file mode 100644
index e65bb99c9ec8..000000000000
--- a/dev-python/future/future-0.16.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Easy, clean, reliable Python 2/3 compatibility"
-HOMEPAGE="http://python-future.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # https://github.com/PythonCharmers/python-future/issues/165
- "${FILESDIR}/${P}-disable-tests-with-internet-connection.patch"
- # https://github.com/PythonCharmers/python-future/pull/355
- "${FILESDIR}/${P}-fix-tests-py37.patch"
-)
-
-python_prepare_all() {
- sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs/ docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- pytest -vv || die "Tests failed under ${EPYTHON}"
-}