summaryrefslogtreecommitdiff
path: root/dev-python/fsspec
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest2
-rw-r--r--dev-python/fsspec/fsspec-2023.10.0.ebuild65
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 0848cf51873d..cda61220f0f1 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,5 +1,3 @@
-DIST filesystem_spec-2023.10.0.gh.tar.gz 404845 BLAKE2B 6c8cf801664c9fc848cb55660db1725c90facf534d58e49f604b2051d1b6a78d13d8f083282071beb7ab3dcb8d75f6d52fe24ce744c5cf1808b4ae3cb673998d SHA512 cb449052208516930c73dbe1de7c495d252677a3d3d85267836224d79c1b8cf9449ebdba8287f6f6206d5a8e631a99cd81c2fb62b82288a626a202876a45139c
DIST filesystem_spec-2024.2.0.gh.tar.gz 424600 BLAKE2B 548f77229dd936437cbafcd4e8df2a5c25e6244ba5c95553cb84eabbb6d8c2aa16313896b4aecbb6c921d01f84c6c5517b13a2cf1552cac0fa29da8034873143 SHA512 ca8c7c448984ecd9b128608f2c028cf32baf3cda3f22addde80c3bef5c1e5644e010b739fb5d28dc951151fdafb4006def080e8c2c769179b1d145ad6e2f9370
-EBUILD fsspec-2023.10.0.ebuild 1708 BLAKE2B 43726784283ca374e767b17e8a0a7af4ead8d161aa0a7f5c56af859eea7d3bb36c0c75d39e2ef4a59846e44d97354ac74d0cea0af7f705f38cd6e8dafe037bd1 SHA512 9c8501b00e7d150200a6540492f98d24f7ca02f389eb7516294984df50c39c065bad75957907c45f2fd156f4568046f33f317b5909032ff736b12f1862a70d43
EBUILD fsspec-2024.2.0.ebuild 1864 BLAKE2B 1ab257d1015b2cd39be95f6370d4082b1800677667569cef6e269b57c4756f5f931387c31c9267c18dcfd755a3478726e06302b01266a077b0432a2c7393b471 SHA512 0b1adda11b7f1ba26f755f4d4d131eb50e98cac476401d1017ca327e0b6eb678e4d49c89fd4f25b5af14c27a58d46de3dfe410ef8245cae91142b0520beab5b9
MISC metadata.xml 374 BLAKE2B 6c0b18a0ad3b85713ae6f618ac0646ed63f08549bd7d1ed5bd94b80d89d79efaf2f97ce913a0a7d6e54e77cc602994416520a22deadcc71e484cf7ca22bc6dde SHA512 5bf051387d6bcffb3022d023f60ee8f76ca277bb8d626dda988a0baaf1d1e3a71e872d8316607ee7e269e579b5a17c23ab93c56fade533150171d3ce44e4bb71
diff --git a/dev-python/fsspec/fsspec-2023.10.0.ebuild b/dev-python/fsspec/fsspec-2023.10.0.ebuild
deleted file mode 100644
index 1cdf466d85da..000000000000
--- a/dev-python/fsspec/fsspec-2023.10.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=filesystem_spec-${PV}
-DESCRIPTION="A specification that python filesystems should adhere to"
-HOMEPAGE="
- https://github.com/fsspec/filesystem_spec/
- https://pypi.org/project/fsspec/
-"
-SRC_URI="
- https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-
-BDEPEND="
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-# Note: this package is not xdist-friendly
-distutils_enable_tests pytest
-
-src_test() {
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- distutils-r1_src_test
-}
-
-EPYTEST_DESELECT=(
- fsspec/tests/test_spec.py::test_find
- # requires s3fs
- fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
- fsspec/tests/test_core.py::test_mismatch
- # requires pyarrow, fastparquet
- fsspec/implementations/tests/test_reference.py::test_df_single
- fsspec/implementations/tests/test_reference.py::test_df_multi
-)
-
-EPYTEST_IGNORE=(
- # sftp and smb require server started via docker
- fsspec/implementations/tests/test_dbfs.py
- fsspec/implementations/tests/test_sftp.py
- fsspec/implementations/tests/test_smb.py
- # unhappy about dev-python/fuse-python (?)
- fsspec/tests/test_fuse.py
-)