summaryrefslogtreecommitdiff
path: root/dev-python/freezegun/freezegun-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/freezegun/freezegun-1.5.0.ebuild')
-rw-r--r--dev-python/freezegun/freezegun-1.5.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/freezegun/freezegun-1.5.0.ebuild b/dev-python/freezegun/freezegun-1.5.0.ebuild
new file mode 100644
index 000000000000..1f3fa418b43f
--- /dev/null
+++ b/dev-python/freezegun/freezegun-1.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Let your Python tests travel through time"
+HOMEPAGE="
+ https://github.com/spulec/freezegun/
+ https://pypi.org/project/freezegun/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ >dev-python/python-dateutil-2.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}