summaryrefslogtreecommitdiff
path: root/dev-python/freezegun/freezegun-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/freezegun/freezegun-1.0.0.ebuild')
-rw-r--r--dev-python/freezegun/freezegun-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/freezegun/freezegun-1.0.0.ebuild b/dev-python/freezegun/freezegun-1.0.0.ebuild
new file mode 100644
index 000000000000..4b7260beae0d
--- /dev/null
+++ b/dev-python/freezegun/freezegun-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Let your Python tests travel through time"
+HOMEPAGE="https://github.com/spulec/freezegun"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="
+ >dev-python/python-dateutil-2.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest