summaryrefslogtreecommitdiff
path: root/dev-python/freezegun/freezegun-0.3.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/freezegun/freezegun-0.3.10.ebuild')
-rw-r--r--dev-python/freezegun/freezegun-0.3.10.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/freezegun/freezegun-0.3.10.ebuild b/dev-python/freezegun/freezegun-0.3.10.ebuild
deleted file mode 100644
index d4902c626999..000000000000
--- a/dev-python/freezegun/freezegun-0.3.10.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Let your Python tests travel through time"
-HOMEPAGE="https://github.com/spulec/freezegun"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/freezegun-0.3.10-py37.patch
-)
-
-python_test() {
- nosetests -v || die "Tests fail with ${EPYTHON}"
-}