summaryrefslogtreecommitdiff
path: root/dev-python/flit_scm/flit_scm-1.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flit_scm/flit_scm-1.6.2.ebuild')
-rw-r--r--dev-python/flit_scm/flit_scm-1.6.2.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/flit_scm/flit_scm-1.6.2.ebuild b/dev-python/flit_scm/flit_scm-1.6.2.ebuild
deleted file mode 100644
index 20e99ab7b703..000000000000
--- a/dev-python/flit_scm/flit_scm-1.6.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A PEP 518 build backend combining flit with setuptools_scm"
-HOMEPAGE="
- https://gitlab.com/WillDaSilva/flit_scm/
- https://pypi.org/project/flit-scm/
-"
-SRC_URI="
- https://gitlab.com/WillDaSilva/flit_scm/-/archive/${PV}/${P}.tar.bz2
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/flit_core-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-6.4.2[${PYTHON_USEDEP}]
- <dev-python/tomli-3[${PYTHON_USEDEP}]
- >=dev-python/tomli-2[${PYTHON_USEDEP}]
-"
-
-src_prepare() {
- # unpin deps
- sed -i -e 's:~=[0-9.]*::' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}