summaryrefslogtreecommitdiff
path: root/dev-python/flit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flit')
-rw-r--r--dev-python/flit/Manifest4
-rw-r--r--dev-python/flit/flit-3.7.1.ebuild1
-rw-r--r--dev-python/flit/flit-3.8.0.ebuild55
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/flit/Manifest b/dev-python/flit/Manifest
index b5220756cf4f..3be778ff3b29 100644
--- a/dev-python/flit/Manifest
+++ b/dev-python/flit/Manifest
@@ -1,3 +1,5 @@
DIST flit-3.7.1.tar.gz 136642 BLAKE2B b94f8bbe00c2c5fb28bddbdcf240255ed53ec3b24d2eab1a33e37261cf32a92a0171ea01ad1488384c15f46acbf84d47c4679b318932a3ee78f22c1d161156b0 SHA512 336e81b034da2f38d7decb32c8961ce62d30f6fd2cb4778b09c956eb400277673d4c94cd57cf08fa7f115f8836aadb0469197d0096f833da9317db8a4f75baed
-EBUILD flit-3.7.1.ebuild 1473 BLAKE2B 260fb336b5102e129b216efa6a5cba93c8d9cfac8c47918c03a3dafc05bc6dfe1b3e8703a0615edc65588666500c9579c8b11c91f06a4cf94047ca411d3a98e9 SHA512 5c67f919d8ca5817a3855394b165cb821eb996180bd81f8831f6935b21b249c46443909ab9c58eaf7f0a063935d664e110aa6b3c6f2318a99bb5b0aac1b4aa0d
+DIST flit-3.8.0.tar.gz 139496 BLAKE2B 85ee9fb13af35bf6716713bd7cf3f5893cd729826ad362aa5ec22077f9b4d16db4d785f183dee37c725b771188f31f2cf38c8e4aedc3af25a3efdc8ff1460bc6 SHA512 08170ee710857fcbfc1f72dbb94c535d70a2477c7598eacacc9a0e2f90f4fe11f4d910f1fcc11de210a6b50d89049e5835127090c6acabb00c69a821919e68cc
+EBUILD flit-3.7.1.ebuild 1502 BLAKE2B d9f0011c34dd1cd297b8259044f918bbb390f59b01a38c1fabb11138dae125ab22373e9ac87582868c2836f2b0144841d2fab3c3647e91640595ec8fce86a679 SHA512 92b4c34b593ea266e3ddf5379edd65eed5517073b36af5c2f797c06d5b275ed701484de3d60a603a47f775ca67ad95d5134e2ec38206eae981eb47fb2af951e6
+EBUILD flit-3.8.0.ebuild 1502 BLAKE2B d9f0011c34dd1cd297b8259044f918bbb390f59b01a38c1fabb11138dae125ab22373e9ac87582868c2836f2b0144841d2fab3c3647e91640595ec8fce86a679 SHA512 92b4c34b593ea266e3ddf5379edd65eed5517073b36af5c2f797c06d5b275ed701484de3d60a603a47f775ca67ad95d5134e2ec38206eae981eb47fb2af951e6
MISC metadata.xml 467 BLAKE2B 534a82783fa3ff1642fc8400689549e75223fa01b175f4ac164d4a636a4c9eaef5bdd9fdd339ffc30239436449788b4d01ebc5e3609034d440c01a5c699176ea SHA512 ad8f3f98a35aa88255bafa81ea9cb109e14b8a544b053cff3f1325dfda3c4c6343a5060353c43a08e030e80a60186eb7dae248d7f6739ea95a7e72e747b1b194
diff --git a/dev-python/flit/flit-3.7.1.ebuild b/dev-python/flit/flit-3.7.1.ebuild
index 5b1ac297822c..a2c1e11caabf 100644
--- a/dev-python/flit/flit-3.7.1.ebuild
+++ b/dev-python/flit/flit-3.7.1.ebuild
@@ -46,6 +46,7 @@ distutils_enable_tests pytest
distutils_enable_sphinx doc \
dev-python/sphinxcontrib-github-alt \
dev-python/pygments-github-lexers \
+ dev-python/sphinx_rtd_theme
src_prepare() {
# make sure system install is used
diff --git a/dev-python/flit/flit-3.8.0.ebuild b/dev-python/flit/flit-3.8.0.ebuild
new file mode 100644
index 000000000000..a2c1e11caabf
--- /dev/null
+++ b/dev-python/flit/flit-3.8.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Simplified packaging of Python modules"
+HOMEPAGE="https://github.com/pypa/flit https://flit.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/flit_core-${PV}[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests_download[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ sys-apps/grep
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # requires Internet
+ tests/test_config.py::test_invalid_classifier
+ # failing due to Gentoo pip patches
+ tests/test_install.py::InstallTests::test_install_data_dir
+ tests/test_install.py::InstallTests::test_install_module_pep621
+ tests/test_install.py::InstallTests::test_symlink_data_dir
+ tests/test_install.py::InstallTests::test_symlink_module_pep621
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/pygments-github-lexers \
+ dev-python/sphinx_rtd_theme
+
+src_prepare() {
+ # make sure system install is used
+ rm -r flit_core || die
+ distutils-r1_src_prepare
+}