summaryrefslogtreecommitdiff
path: root/dev-python/flexmock/flexmock-0.10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flexmock/flexmock-0.10.2.ebuild')
-rw-r--r--dev-python/flexmock/flexmock-0.10.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/flexmock/flexmock-0.10.2.ebuild b/dev-python/flexmock/flexmock-0.10.2.ebuild
new file mode 100644
index 000000000000..21a1616d30e2
--- /dev/null
+++ b/dev-python/flexmock/flexmock-0.10.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing library to create mocks, stubs and fakes"
+HOMEPAGE="http://flexmock.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ "
+RDEPEND=""
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}
+
+python_test() {
+ pytest -vv tests || die "pytest failed"
+}