summaryrefslogtreecommitdiff
path: root/dev-python/flask/flask-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask/flask-9999.ebuild')
-rw-r--r--dev-python/flask/flask-9999.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/dev-python/flask/flask-9999.ebuild b/dev-python/flask/flask-9999.ebuild
index feea1195fdd3..eec62df569de 100644
--- a/dev-python/flask/flask-9999.ebuild
+++ b/dev-python/flask/flask-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
@@ -15,7 +17,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
S="${WORKDIR}/${MY_P}"
fi
@@ -24,14 +26,19 @@ SLOT="0"
IUSE="examples"
RDEPEND="
- >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
dev-python/blinker[${PYTHON_USEDEP}]
>=dev-python/itsdangerous-2.0[${PYTHON_USEDEP}]
>=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]"
+ >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
BDEPEND="
test? (
>=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
+ !!dev-python/shiboken2
)"
distutils_enable_sphinx docs \