summaryrefslogtreecommitdiff
path: root/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild')
-rw-r--r--dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild b/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild
new file mode 100644
index 000000000000..a4ace992473f
--- /dev/null
+++ b/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Sphinx-Themes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sphinx Themes for Flask related projects and Flask itself"
+HOMEPAGE="https://github.com/pallets/flask-sphinx-themes https://pypi.org/project/Flask-Sphinx-Themes/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-python2-encoding-kw.patch" )
+
+S="${WORKDIR}/${MY_P}"