summaryrefslogtreecommitdiff
path: root/dev-python/flask-peewee/flask-peewee-0.6.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-peewee/flask-peewee-0.6.7.ebuild')
-rw-r--r--dev-python/flask-peewee/flask-peewee-0.6.7.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/flask-peewee/flask-peewee-0.6.7.ebuild b/dev-python/flask-peewee/flask-peewee-0.6.7.ebuild
new file mode 100644
index 000000000000..cddfc580b3ff
--- /dev/null
+++ b/dev-python/flask-peewee/flask-peewee-0.6.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Flask integration layer for the Peewee ORM"
+HOMEPAGE="https://pypi.org/project/Flask-Admin/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+ dev-python/wtf-peewee[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+
+ distutils-r1_python_install_all
+}