summaryrefslogtreecommitdiff
path: root/dev-python/flask-nav/flask-nav-0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-nav/flask-nav-0.6.ebuild')
-rw-r--r--dev-python/flask-nav/flask-nav-0.6.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/dev-python/flask-nav/flask-nav-0.6.ebuild b/dev-python/flask-nav/flask-nav-0.6.ebuild
index 2c76b7a87243..e954296d7bf4 100644
--- a/dev-python/flask-nav/flask-nav-0.6.ebuild
+++ b/dev-python/flask-nav/flask-nav-0.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
inherit distutils-r1
@@ -20,6 +20,7 @@ IUSE="doc test"
RDEPEND="
dev-python/dominate[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
dev-python/visitor[${PYTHON_USEDEP}]
"
DEPEND="
@@ -28,7 +29,6 @@ DEPEND="
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
)
"
@@ -38,14 +38,12 @@ python_prepare_all() {
}
python_compile_all() {
- use doc && emake -C docs html
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
}
python_test() {
py.test || die "Tests failed with ${EPYTHON}"
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}