summaryrefslogtreecommitdiff
path: root/dev-python/flask-migrate/flask-migrate-2.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-migrate/flask-migrate-2.7.0.ebuild')
-rw-r--r--dev-python/flask-migrate/flask-migrate-2.7.0.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/flask-migrate/flask-migrate-2.7.0.ebuild b/dev-python/flask-migrate/flask-migrate-2.7.0.ebuild
deleted file mode 100644
index e72818dcefbe..000000000000
--- a/dev-python/flask-migrate/flask-migrate-2.7.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-MY_PN="Flask-Migrate"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="SQLAlchemy database migrations for Flask applications using Alembic"
-HOMEPAGE="https://pypi.org/project/Flask-Migrate/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/alembic-0.7[${PYTHON_USEDEP}]
- >=dev-python/flask-0.9[${PYTHON_USEDEP}]
- >=dev-python/flask-sqlalchemy-1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( >=dev-python/flask-script-0.6[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_tests setup.py