summaryrefslogtreecommitdiff
path: root/dev-python/fido2
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest2
-rw-r--r--dev-python/fido2/fido2-1.1.3.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index 2e626f0de34e..ef8b56f31e05 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -1,5 +1,7 @@
DIST fido2-0.9.3.tar.gz 217894 BLAKE2B ccc3a9b59045216037664b5bf4b969a79b86b300f67fc4253b563acbbee98912ea076996772f17b88141d2a36a933b4926de96f05c53e204d0bb4eaaa2daad6b SHA512 f105c347784cdfab88ab08852227d24f4bca623145f7f76bd066dadab6ada1eae751934fd4dc7436a5c5fb3a0ed2fc4d5c59bb2a93888d470028f0713ca7e09e
DIST fido2-1.1.2.tar.gz 248554 BLAKE2B d2a8afb5fa00d3f3debd4632ae7e3bd4e28b10574d0fc76e78db4bb6408b308e4aa7378caf6fcd87ea3d49ce3db70b879288ea0cd5d0dbd7d5131bceb0eea137 SHA512 db62cfc05a8daa2224bae820ba3174f22d1e4711643d52f549e738e4af14537f92ca950c3904660f3bb360d6aadf236c9b19b8ac4816d99467a43e239b7c219a
+DIST fido2-1.1.3.tar.gz 252813 BLAKE2B f88ddd1c201aefddbf8c0a91040a121a3ba446229f90c17df6114c6b7fd3c047a4089475601f2d7d38d06fcd5fd14dba25177fa2b22360226a7c90d66137e978 SHA512 9ee226ab5762afe263c917d24ddfded9f3da40b38f97383c25c5fbfc3adc6085d3d218dc5f12b288689bf2e5e89fe9cecb2e40e45e5441d2001f945b336c2d0b
EBUILD fido2-0.9.3-r1.ebuild 1096 BLAKE2B af45862476b4ad09caeab6bba0b64fadf33de9b0a966268d522d2231d0ebce74eda9d14c41f109dbc2e016958ff26009ca5c318cbf86bec25737a4d59369c93e SHA512 d441a6810d9364e11a9418e9d3d822b62db714ca2b74188881cb473d40740136c28e8e2502f267873f12bc53067ffaa4942197f6f239d6a161d81664a0e31218
EBUILD fido2-1.1.2.ebuild 1002 BLAKE2B 7c4d99ef22d30c72551b1da764c0bf869cc32abcc6517c4f1d0808cd9f0b20932156b64677f3fc497575f6e7fb737354512b91f0ee2a64a91f7fb93c87eb0da1 SHA512 c1603c398bc726656b7c7d96c4ceebab043a73c802017950df117ce99e4157b795512205b49af6cdfd15efe25b15ed484aba6ebf04a35324a8cd83abf2be6e1a
+EBUILD fido2-1.1.3.ebuild 1005 BLAKE2B 5040b43c443945e2f1921622c0914da73a757f46bc9154fc80e33dd8ff5a4eba2eb28332ddfd304e120125a7cc0f3424cb758ed196b9fcf1de4cc7fd4cd25213 SHA512 2a3bceee8bd8f656369dc5fa3943de2c10dd1ed3702645f85052f3447e0ab6ced5958307a61160f57d0a0c6533908ce3f7496c51580247ef173301ef35112c28
MISC metadata.xml 820 BLAKE2B 092fc3aa0dc3e3a8998e7cef0a3229d5b8791983dc07df84c74ff6b7221afc879aa5a39a6ad58ff0bfe2836fa48b57d3445f20a0c78e2affc3bc47b73b81544b SHA512 f588e6637d75b668dabf80fc2c8e1133119a770d4f7fa5077025e0a478f8eb9c7f18eac1ce15395549485625bc4c82bdeebf07440087cd074e95d42a685eef53
diff --git a/dev-python/fido2/fido2-1.1.3.ebuild b/dev-python/fido2/fido2-1.1.3.ebuild
new file mode 100644
index 000000000000..6a44c1f16acd
--- /dev/null
+++ b/dev-python/fido2/fido2-1.1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="
+ https://github.com/Yubico/python-fido2/
+ https://pypi.org/project/fido2/
+"
+SRC_URI="
+ https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0/1.0" # Bumped every time a backwards-incompatible version is released
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/cryptography-44[${PYTHON_USEDEP}]
+ <dev-python/pyscard-3[${PYTHON_USEDEP}]
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}