summaryrefslogtreecommitdiff
path: root/dev-python/fasteners/fasteners-0.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fasteners/fasteners-0.18.ebuild')
-rw-r--r--dev-python/fasteners/fasteners-0.18.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/fasteners/fasteners-0.18.ebuild b/dev-python/fasteners/fasteners-0.18.ebuild
new file mode 100644
index 000000000000..202225cc48d9
--- /dev/null
+++ b/dev-python/fasteners/fasteners-0.18.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python package that provides useful locks"
+HOMEPAGE="https://github.com/harlowja/fasteners/"
+SRC_URI="
+ https://github.com/harlowja/fasteners/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/diskcache[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests_eventlet/test_eventlet.py
+)