summaryrefslogtreecommitdiff
path: root/dev-python/expects/expects-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/expects/expects-0.9.0.ebuild')
-rw-r--r--dev-python/expects/expects-0.9.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/expects/expects-0.9.0.ebuild b/dev-python/expects/expects-0.9.0.ebuild
new file mode 100644
index 000000000000..164210bad0d2
--- /dev/null
+++ b/dev-python/expects/expects-0.9.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
+HOMEPAGE="https://github.com/jaimegildesagredo/expects"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/mamba[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ mamba || die "tests failed under ${EPYTHON}"
+}