summaryrefslogtreecommitdiff
path: root/dev-python/execnet
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/Manifest6
-rw-r--r--dev-python/execnet/execnet-2.0.2.ebuild32
-rw-r--r--dev-python/execnet/execnet-2.1.0.ebuild37
-rw-r--r--dev-python/execnet/execnet-2.1.1.ebuild2
4 files changed, 2 insertions, 75 deletions
diff --git a/dev-python/execnet/Manifest b/dev-python/execnet/Manifest
index 4bf9ab8059ff..683e15e69a2c 100644
--- a/dev-python/execnet/Manifest
+++ b/dev-python/execnet/Manifest
@@ -1,7 +1,3 @@
-DIST execnet-2.0.2.tar.gz 161098 BLAKE2B 2a0a4d3071a0436d7c6ec450f1b502047e6a367985771aa58050e149ea060e8a573844bd2380c66be914dd00e3f9491b126e84089006787c61c043116f9e5981 SHA512 9e2e7ff4e04f50b12a3dd47d3326a3ea229f64926e8598bdce6ea25bd57afb41e96249e1c9f7333927a38a2793f67cac77965c922980055ed758dee361bf2ce4
-DIST execnet-2.1.0.tar.gz 166475 BLAKE2B b1149df5e0073ad9e02520bd74a19a3e527a488088d785b902fab2e7d008fe01195134d2742d6443a52645338b79bc69283ad3402495d64089885793446c4aad SHA512 efd63147748d2f26fd75034b2a0a90c7aa10ac647468ceb27c845c3b66dfa6ffda8b8bd3b5d40ce34f429fb151bfd9fe5c2c6ebc20027789de555232851b5525
DIST execnet-2.1.1.tar.gz 166524 BLAKE2B cf6ef7007ecee7cd3e205dfaefc7c46dcc555dd4290a9055413373cbc1f8b24c5769e8e2eb58c9d6169ad766539bf44139a691726d791a69a80a2f800fefcf4e SHA512 486f906ad653d16cce7337d9085c36070fe3dd721a3723ca62ceb25862c3ff837120062df028d5aadec17f854c0d46204537e9d75d22079a677f08c50dd48d21
-EBUILD execnet-2.0.2.ebuild 692 BLAKE2B 3f36ecd0fa2d0279c0f1089c9248ce639c12a89293a488d88b2a144a141db63985d906bc4cca5c57d35f4f505be401e4633508a70a129c7a4c8bfb6b22ff8a1e SHA512 986f19c0091d28ae4200cbebaa21084d363f3049d4a91455550d1f1577588b8c266b36359f452fc2e8c1890d929c4102507328fded8077b2ab03e986d673f35d
-EBUILD execnet-2.1.0.ebuild 992 BLAKE2B b6f4150a6732536d3029659851d85076a56422e836f260e1245e986ed8e70bd64d846fe5998c0a1317e491688f24dd88411ced5e782ec9ba56a5521f379410db SHA512 b74b409b71a3a7e302eba88de545dcfaa5207a926b294c94f122fc8fe989f6108653d782641e1036980c8c15a9ee6dee0432435f53fc659ea822348a28c57b3c
-EBUILD execnet-2.1.1.ebuild 992 BLAKE2B b6f4150a6732536d3029659851d85076a56422e836f260e1245e986ed8e70bd64d846fe5998c0a1317e491688f24dd88411ced5e782ec9ba56a5521f379410db SHA512 b74b409b71a3a7e302eba88de545dcfaa5207a926b294c94f122fc8fe989f6108653d782641e1036980c8c15a9ee6dee0432435f53fc659ea822348a28c57b3c
+EBUILD execnet-2.1.1.ebuild 984 BLAKE2B d3c2fbeccc118b515da4daa7dfba541c0d97f376ab86e9c46d58f01409878a79509a4ee02e3566053a578ed832793deca73c840a133f5ea4cc0add72723b8740 SHA512 687cca1bb48f12051fdaa1c362662dedd79273b5ad387aa8b70509f0cec57296a97a9f847c8df5d97b7ac364820e17163c50487e2dc4d6a5fbd9da2c1a49ab3c
MISC metadata.xml 500 BLAKE2B 56db909a3d278407df77dd3bdf0bc213d181342773f6c703004b2680ea69dda18632cbecb267653dbbe0dde924eb2171ee6701b8587e6c6cba8e0f2285c9e313 SHA512 c27f05cf4d9510a746f1dfc70f8e758437f43bd6c5265b80bfdc3c338d5b38b1b73406cb572af04a26034933ccf04f3bfdd97227b54b026776849d5a9a217cd1
diff --git a/dev-python/execnet/execnet-2.0.2.ebuild b/dev-python/execnet/execnet-2.0.2.ebuild
deleted file mode 100644
index c6707acf4de6..000000000000
--- a/dev-python/execnet/execnet-2.0.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Rapid multi-Python deployment"
-HOMEPAGE="
- https://codespeak.net/execnet/
- https://github.com/pytest-dev/execnet/
- https://pypi.org/project/execnet/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTHONDONTWRITEBYTECODE=
- epytest testing
-}
diff --git a/dev-python/execnet/execnet-2.1.0.ebuild b/dev-python/execnet/execnet-2.1.0.ebuild
deleted file mode 100644
index c954dbc26c01..000000000000
--- a/dev-python/execnet/execnet-2.1.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Rapid multi-Python deployment"
-HOMEPAGE="
- https://codespeak.net/execnet/
- https://github.com/pytest-dev/execnet/
- https://pypi.org/project/execnet/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
-
-python_test() {
- # the test suite checks if bytecode writing can be disabled/enabled
- local -x PYTHONDONTWRITEBYTECODE=
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # some tests are implicitly run against both sys.executable
- # and pypy3, which is redundant and results in pypy3 bytecode being
- # written to cpython install dirs
- epytest testing -k "not pypy3"
-}
diff --git a/dev-python/execnet/execnet-2.1.1.ebuild b/dev-python/execnet/execnet-2.1.1.ebuild
index c954dbc26c01..5bef9406728d 100644
--- a/dev-python/execnet/execnet-2.1.1.ebuild
+++ b/dev-python/execnet/execnet-2.1.1.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
BDEPEND="
dev-python/hatch-vcs[${PYTHON_USEDEP}]