summaryrefslogtreecommitdiff
path: root/dev-python/exam
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/exam')
-rw-r--r--dev-python/exam/Manifest2
-rw-r--r--dev-python/exam/metadata.xml33
2 files changed, 18 insertions, 17 deletions
diff --git a/dev-python/exam/Manifest b/dev-python/exam/Manifest
index e3df504d6889..6c4718adff9c 100644
--- a/dev-python/exam/Manifest
+++ b/dev-python/exam/Manifest
@@ -1,3 +1,3 @@
DIST exam-0.10.6.tar.gz 15028 BLAKE2B 6d2a888b9adf14665e8f009bae7b2c724dcb60fe19efa98a189988a73a0cb5933179407c754ed1c19b24694080b6df31838768f694460fabd9196e58e8b4c94d SHA512 1cc082b4fb9a7270ea81750ee3f34400f3f6eac65dd1488af333a43d0623bf8f9176b73e2948c324bb9c0062296284bae66fe215263456baf9db378676c8a4f0
EBUILD exam-0.10.6.ebuild 424 BLAKE2B ccb3c8637031aab37f599b82c2186f2c8b54f00d6c0368f9d80b0c10e36c3ece8652fc4f466ccd98733d5df0fe57c71d3b5e346887f739ca2a66f3d9e3affbf6 SHA512 59c8b5845fc2b46610e046be4a95053b6284c7fb44276d77c8a569706555a207673c3e5328040659284db9b161085dce731a9b166fa603aec65deb90b2b7cf3b
-MISC metadata.xml 1685 BLAKE2B 51e5e8f94272ea0318f683f1868e3d2519f492d4b3a4870990ff574fa08dd094ea976e56b8cede7e554ebc8471685c6efaf13355735c021e881c96200d3412d0 SHA512 48974f1aa263535521d2691b715f4500f512ca903fd325339a7614cfe25ca836af17aca742e2d4939752c8acb741380a4e5ce6ae3fad2b3babbad85f8e06e48e
+MISC metadata.xml 1700 BLAKE2B 9448f77935050f99836bbf1aae4fd140dcadb1c620271eb5316ff92ea9de74f5958467c53ed0cfc36f1cf931bcd85b8492eb73029fe6e66fc6688edbdee6a113 SHA512 592bfcec70460045e61e4e8abf6043e18861018d27b2ca7684f364242c790bd6e2d984bdcfbb9aeed696f6d6f2f51790c53b11a09653fe8e8b39fbac3ffc051a
diff --git a/dev-python/exam/metadata.xml b/dev-python/exam/metadata.xml
index e782094b1d21..d79043f73e5b 100644
--- a/dev-python/exam/metadata.xml
+++ b/dev-python/exam/metadata.xml
@@ -1,28 +1,29 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>lssndrbarbieri@gmail.com</email>
- <name>Alessandro Barbieri</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <upstream>
- <remote-id type="github">fluxx/exam</remote-id>
- </upstream>
- <longdescription lang="en">
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fluxx/exam</remote-id>
+ <remote-id type="pypi">exam</remote-id>
+ </upstream>
+ <longdescription lang="en">
Exam is a Python toolkit for writing better tests. It aims to remove a lot of the boiler plate testing code one often writes, while still following Python conventions and adhering to the unit testing interface.
Aside from the obvious "does the code work?", writings tests has many additional goals and benefits:
- If written semantically, reading tests can help demonstrate how the code is supposed to work to other developers.
- If quick running, tests provide feedback during development that your changes are working or not having an adverse side effects.
- If they're easy to write correctly, developers will write more tests and they will be of a higher quality.
+ If written semantically, reading tests can help demonstrate how the code is supposed to work to other developers.
+ If quick running, tests provide feedback during development that your changes are working or not having an adverse side effects.
+ If they're easy to write correctly, developers will write more tests and they will be of a higher quality.
Unfortunately, the common pattern for writing Python unit tests tends to not offer any of these advantages. Often times results in inefficient and unnecessarily obtuse testing code. Additionally, common uses of the mock library can often result in repetitive boiler-plate code or inefficiency during test runs.
exam aims to improve the state of Python test writing by providing a toolkit of useful functionality to make writing quick, correct and useful tests and as painless as possible.
- </longdescription>
+ </longdescription>
</pkgmetadata>