summaryrefslogtreecommitdiff
path: root/dev-python/environs/environs-9.3.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/environs/environs-9.3.4.ebuild')
-rw-r--r--dev-python/environs/environs-9.3.4.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/environs/environs-9.3.4.ebuild b/dev-python/environs/environs-9.3.4.ebuild
deleted file mode 100644
index 0f6b134c4b42..000000000000
--- a/dev-python/environs/environs-9.3.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python library for simplified environment variable parsing"
-HOMEPAGE="https://github.com/sloria/environs"
-SRC_URI="https://github.com/sloria/environs/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- dev-python/marshmallow[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/django-cache-url[${PYTHON_USEDEP}]
- dev-python/dj-database-url[${PYTHON_USEDEP}]
- dev-python/dj-email-url[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-distutils_enable_tests pytest