summaryrefslogtreecommitdiff
path: root/dev-python/entrypoint2/entrypoint2-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/entrypoint2/entrypoint2-0.2.1.ebuild')
-rw-r--r--dev-python/entrypoint2/entrypoint2-0.2.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/entrypoint2/entrypoint2-0.2.1.ebuild b/dev-python/entrypoint2/entrypoint2-0.2.1.ebuild
new file mode 100644
index 000000000000..fc2e650b9d50
--- /dev/null
+++ b/dev-python/entrypoint2/entrypoint2-0.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to use command-line interface for python modules"
+HOMEPAGE="https://github.com/ponty/entrypoint2"
+SRC_URI="https://github.com/ponty/entrypoint2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest