summaryrefslogtreecommitdiff
path: root/dev-python/elastic-transport
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/elastic-transport')
-rw-r--r--dev-python/elastic-transport/Manifest4
-rw-r--r--dev-python/elastic-transport/elastic-transport-8.12.0.ebuild64
-rw-r--r--dev-python/elastic-transport/elastic-transport-8.13.0.ebuild2
3 files changed, 2 insertions, 68 deletions
diff --git a/dev-python/elastic-transport/Manifest b/dev-python/elastic-transport/Manifest
index 7f04f3e05e7a..b0154a7c9141 100644
--- a/dev-python/elastic-transport/Manifest
+++ b/dev-python/elastic-transport/Manifest
@@ -1,5 +1,3 @@
-DIST elastic-transport-python-8.12.0.gh.tar.gz 72207 BLAKE2B 7777484c965eb893cd7d2cba1d39c2b33a005e7f6d6b3c12dd1cd0fb4e5c396abf36686421817ba1272e814ffef299453c885a6dcc3efe5cacd753bcd621384e SHA512 45834ccb4793d7aa7c7d1774ef26381b7ff0cf69221cc628efeb63a7ff8b163a68ff7f0ef4fa3a2b5ffd45e9374441d8b61b8a9b900f9055ddd67425cf0d727a
DIST elastic-transport-python-8.13.0.gh.tar.gz 75950 BLAKE2B 5a62d28ece9570d8fc4fff30cf04f88e7e138276054bb191c883c156995effcb750aef874836e5fb32cecedf79641f8faa08ab2e3c74bf5d0c2ba950f490ffb8 SHA512 65239951d56efa4273b8023cf4caa04f44196d0f9bcad91fe5376139adbd669d76a9c0e673f8eec23aadf107fea315216ecf95064acfa5eeb769ca3b92885fb6
-EBUILD elastic-transport-8.12.0.ebuild 1603 BLAKE2B 95871fe70ab33e20550de8a46d4aac28f638b583f3f781653930b49d3ecd1d51ae6430de7a92e1a1bf558ea12be8c66b92447e21701077687832b64f2c4475ff SHA512 2537e2e34fc88ffd49a96e02057b2cb9a118e2e4a1d02a71e78efddcab45ba8e96b08674bb1166af282fb5fe1ca575837bc7981327a2be4fc6f73f69e45e8c01
-EBUILD elastic-transport-8.13.0.ebuild 1820 BLAKE2B afca69427409085051b83f698814ae1e7cf1bdd13eb2c733a833c58b01be3bda46fcc3d5fdb86a2da3a90504a383b9277cdb236e142533a5868483909584d8b1 SHA512 5d1dfa953ccd505473a1ff42602a974ab217ce8a5b91e3af58372ef2e3f0ad96d3bb67f5502c876ee609b309ee3f19cf74f033eaa966e65c17f69ea47ac7beb5
+EBUILD elastic-transport-8.13.0.ebuild 1829 BLAKE2B 29447d9848f2a3aa601a24d785ad3acb1de0637c272c5909f1063053e399c1382963b5c9dab62d1d860868f676a0d27efaf62d96ee05105d17d774a52e7759e9 SHA512 d76655ef9ca28d0718613deccb1679628f423be5746bb15299f5b30b5096aaef137a7db1fc286afed5c8e53fabe08d499549a1def6283e61e55d4bda3d70cd7d
MISC metadata.xml 658 BLAKE2B 7ba1da27d590421cdd7a24d01d38771b27ae65f09521e39bc84e691f3e587a3bccabcdd297350166e00324ca482dd0459e8213ed578d81f9e93469fd3efec48d SHA512 c39cf837ff098fb09c25d1933f43c0f20e1b2b5ae4e1bb5aa172aac43f8f36ea80437e3e59909b0c51d0f8301853bdb6b5dbd7f3498502baa8936939bc0210d8
diff --git a/dev-python/elastic-transport/elastic-transport-8.12.0.ebuild b/dev-python/elastic-transport/elastic-transport-8.12.0.ebuild
deleted file mode 100644
index e0227217b3b3..000000000000
--- a/dev-python/elastic-transport/elastic-transport-8.12.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=elastic-transport-python-${PV}
-DESCRIPTION="Transport classes and utilities shared among Python Elastic client libraries"
-HOMEPAGE="
- https://github.com/elastic/elastic-transport-python/
- https://pypi.org/project/elastic-transport/
-"
-SRC_URI="
- https://github.com/elastic/elastic-transport-python/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.26.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-httpserver[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/sphinx \
- dev-python/furo \
- dev-python/sphinx-autodoc-typehints
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin deps
- sed -i -e 's:, *<[0-9.]*::' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # fragile to random warnings
- tests/node/test_http_aiohttp.py::TestAiohttpHttpNode::test_uses_https_if_verify_certs_is_off
- tests/node/test_urllib3_chain_certs.py::test_assert_fingerprint_in_cert_chain
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -o addopts=
-}
diff --git a/dev-python/elastic-transport/elastic-transport-8.13.0.ebuild b/dev-python/elastic-transport/elastic-transport-8.13.0.ebuild
index 929ad572fafa..ac32b5ea4bde 100644
--- a/dev-python/elastic-transport/elastic-transport-8.13.0.ebuild
+++ b/dev-python/elastic-transport/elastic-transport-8.13.0.ebuild
@@ -22,7 +22,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64 arm64 x86"
PROPERTIES="test_network"
RESTRICT="test"