summaryrefslogtreecommitdiff
path: root/dev-python/easyprocess/easyprocess-1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/easyprocess/easyprocess-1.1.ebuild')
-rw-r--r--dev-python/easyprocess/easyprocess-1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/easyprocess/easyprocess-1.1.ebuild b/dev-python/easyprocess/easyprocess-1.1.ebuild
new file mode 100644
index 000000000000..f17744f48ed2
--- /dev/null
+++ b/dev-python/easyprocess/easyprocess-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to use Python subprocess interface"
+HOMEPAGE="https://github.com/ponty/EasyProcess"
+SRC_URI="https://github.com/ponty/EasyProcess/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/EasyProcess-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # looks like a problem within imagemagick itself
+ tests/test_fast/test_deadlock.py::test_has_imagemagick
+ # TODO
+ tests/test_fast/test_deadlock.py::test_deadlock_pipe
+)