summaryrefslogtreecommitdiff
path: root/dev-python/dynd-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dynd-python')
-rw-r--r--dev-python/dynd-python/Manifest1
-rw-r--r--dev-python/dynd-python/dynd-python-0.7.2-r2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/dynd-python/Manifest b/dev-python/dynd-python/Manifest
index 4669be4cb1a9..6adb619b614a 100644
--- a/dev-python/dynd-python/Manifest
+++ b/dev-python/dynd-python/Manifest
@@ -1,3 +1,4 @@
DIST dynd-python-0.7.2.tar.gz 184981 BLAKE2B 826a46c7c920533dbd64f310ce6136e37f5d3f7e2bb1190977c72e9c7b65aa9957547b02ca92f5aadc1db268ca4ceda9459036e9fe24a57e090f4312645d348b SHA512 e51df7b368b1f6869338cb12a2f093064b1e7531ef674a83dbc7b9cc1dc6143cbe12cb37273bcc01e7b1066eda541b3b15473bc01e88fd9a8d1b594f6f37eaba
EBUILD dynd-python-0.7.2-r1.ebuild 1561 BLAKE2B 5dd010bbcf489758db2829a6b8797111f3876b2bbd1dfd3a8f7925ff9d249d05b8f01e721cf525a778c1139e90c1020f95822018e1189b85c1489bdfdc1fc140 SHA512 65c28ea1e930b4389e9f37de825af0b1b96a44ebf79b9e14eb85fae3405622e8cea2ac6972246c6e2456b77203eb0dadecf3bad97c1fe9ae44d3c7595ffe74b9
+EBUILD dynd-python-0.7.2-r2.ebuild 1552 BLAKE2B f972e9d4ba27bc6a257fa9a0c35e6a9e0afc18d2d35b1e60733a2020b99707ec9ae83ba25282b1e59a20cd813f4d468a5f4aa863080118e564668edfbb742a5b SHA512 8410943435e5566ed8cfcfd52472b70fae84d8a8c5a4d7b12289f551c8d410c68dc98ecea8289314e6cacb3839bf7ad84f821284b44eb8b6f2f37b4b42f5bdfd
MISC metadata.xml 529 BLAKE2B bc365c7019af30defbcddf4eb0c590666199d43acba144d4b42f21fecea7c572d6122b60bd0b767437ec4b1887e7d3bc50c50b83f88deb99e627cb67030ec95f SHA512 8500904a91a51d552ef6f0fe17486b8d935bc4f50860120376ed40a31c002bda8ca66b5c3c8b8c244dccf659cbf8574f1e031e62a0a0b870af133062055a25b9
diff --git a/dev-python/dynd-python/dynd-python-0.7.2-r2.ebuild b/dev-python/dynd-python/dynd-python-0.7.2-r2.ebuild
new file mode 100644
index 000000000000..190b19a824e4
--- /dev/null
+++ b/dev-python/dynd-python/dynd-python-0.7.2-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+# change each new dynd version, to avoid git in tree dependency
+DYND_PYTHON_GIT_SHA1=8cdef57e71c784d7fe1f3f97a2ce2ce5727a89f1
+
+DESCRIPTION="Python exposure of multidimensionnal array library libdynd"
+HOMEPAGE="http://libdynd.org/"
+SRC_URI="https://github.com/libdynd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ ~dev-libs/libdynd-${PV}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # remove the version mangling from git stuff it requires a git clone
+ # rather force set it a configure time
+ sed -e "/--dirty/s/ver =.*/ver = 'v${PV}'/" \
+ -e '/--always/d' \
+ -i setup.py || die
+ sed -e "s/get_git.*/set(DYND_PYTHON_GIT_SHA1 ${DYND_PYTHON_GIT_SHA1})/" \
+ -e "s/git_describe.*/set(DYND_PYTHON_VERSION_STRING v${PV})/" \
+ -e 's|-g -fomit-frame-pointer||' \
+ -e 's|-Werror||g' \
+ -i CMakeLists.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ PYTHONPATH=${BUILD_DIR}/lib nosetests -v || die
+}