summaryrefslogtreecommitdiff
path: root/dev-python/dulwich
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest2
-rw-r--r--dev-python/dulwich/dulwich-0.21.6.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 3db8612e17e2..9bb1bdf8ec39 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,3 +1,5 @@
DIST dulwich-0.21.5.tar.gz 441948 BLAKE2B a65aaa3611de6b18a3f63bd195d3831733bea726f634964c14bb817954147e45753868982fb0c3dcf57dec5a2ed8c985229d110234fd6cae8c783367a06bc20c SHA512 5966a4df8ef94d4c61c4e0a2aebbf11b7f9072139f11357e5194e58dc4edfbe83eb76f7b7aa3a52f96f97c5b7908850fcef5de2aa4bccb212126bb21fdc53934
+DIST dulwich-0.21.6.tar.gz 445545 BLAKE2B a3189b4777e295bf26345172fa1c4f6ca4c45e807a9197cd2bc8c0255a9ebb7fa752bc98369ffe780671dc9610fefb1fc4bd9b6b75d90b7322d048197da0aeaa SHA512 24f1d82be08b6ee78e41cd86ec2323a51dd6bff3714b1eae1f8484eda316c9d1c8089ded853511d587898ba789d36ee014c8f3b7c718bf7168519725f4d9dc2c
EBUILD dulwich-0.21.5.ebuild 1474 BLAKE2B 5e4e58906a45508b72a6a136f55270c3ef484d20584e936b092e1f43dcd4ebe64f52e858ea417ae54450e48d711b2224e72f8d5daa1e1e94598fb1e807992bbb SHA512 2a3f5d1be375b9278bf7c32547b44a8b500ca58bf98c7886b05d8055a0635e6a0430518205f20e98ed44c772a9a4f8f9265dc629bc25cb187915d796ace63413
+EBUILD dulwich-0.21.6.ebuild 1478 BLAKE2B 2ef87388c08995c811dd9ce7ec43ea73bde6d4da97ce5588cd616d8ed3b8b07c195b9c0c2a4d5c1873e7296b0fdb56ab2f815e4f76fe7a79d7664d54bb39e093 SHA512 b2143071d49954afad2dbebf292fb6a604cb4959185d1561ee06b99c174fbf6985accbb9d447d95a4125656a04740b4d7888a815ab465913938d6e197647eedd
MISC metadata.xml 556 BLAKE2B 240554ff522160e9508bf6debadafcc44b5ccc4074dd4c9d3ce82358963084c60a1afae9fafee6ab1e6e5d898940ccb4d1b524cebff155e61bf6707c9396b647 SHA512 a7cdca224a01d5bd26bf4a5adb0273977ddff61f75cd02f5642132656fd0c6608114617efcb068d834f107804666cf4fb3725967e804b73d2ddcb67342dc30de
diff --git a/dev-python/dulwich/dulwich-0.21.6.ebuild b/dev-python/dulwich/dulwich-0.21.6.ebuild
new file mode 100644
index 000000000000..f4770bb6ca22
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.21.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="
+ https://github.com/jelmer/dulwich/
+ https://pypi.org/project/dulwich/
+"
+
+LICENSE="GPL-2+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/fastimport[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE
+ unset GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE
+ unset EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}