summaryrefslogtreecommitdiff
path: root/dev-python/duecredit/duecredit-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/duecredit/duecredit-0.9.1.ebuild')
-rw-r--r--dev-python/duecredit/duecredit-0.9.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/duecredit/duecredit-0.9.1.ebuild b/dev-python/duecredit/duecredit-0.9.1.ebuild
new file mode 100644
index 000000000000..da81018c7a20
--- /dev/null
+++ b/dev-python/duecredit/duecredit-0.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Publications (and donations) tracer"
+HOMEPAGE="https://github.com/duecredit/duecredit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/citeproc-py-0.4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # internet?
+ 'duecredit/tests/test_api.py::test_noincorrect_import_if_no_lxml_numpy[kwargs1-env2]'
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}