summaryrefslogtreecommitdiff
path: root/dev-python/doublex/doublex-1.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/doublex/doublex-1.9.2.ebuild')
-rw-r--r--dev-python/doublex/doublex-1.9.2.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/dev-python/doublex/doublex-1.9.2.ebuild b/dev-python/doublex/doublex-1.9.2.ebuild
index 43ec6b36311a..167fc6a19c20 100644
--- a/dev-python/doublex/doublex-1.9.2.ebuild
+++ b/dev-python/doublex/doublex-1.9.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1 vcs-snapshot
@@ -13,7 +13,7 @@ SRC_URI="https://bitbucket.org/DavidVilla/python-${PN}/get/v${PV}.tar.gz -> ${P}
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64"
+KEYWORDS="amd64 ~arm64"
IUSE="doc test"
RESTRICT="!test? ( test )"
@@ -27,6 +27,16 @@ RDEPEND="${CDEPEND}"
distutils_enable_tests setup.py
+python_prepare_all() {
+ # Disable broken tests
+ # https://bitbucket.org/DavidVilla/python-doublex/issues/5/support-for-python-36-37-38-tests-failing
+ sed -i "s/test_*hamcrest_/_&/" doublex/test/report_tests.py || die
+ # https://bitbucket.org/DavidVilla/python-doublex/issues/6/more-failing-tests-with-python-39
+ sed -i -r "s/test_(proxyspy_get_stubbed_property|stub_property|custom_equality_comparable_objects)/_&/" \
+ doublex/test/unit_tests.py || die
+ distutils-r1_python_prepare_all
+}
+
python_compile_all() {
use doc && emake -C docs
}