summaryrefslogtreecommitdiff
path: root/dev-python/doublex-expects/doublex-expects-0.7.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/doublex-expects/doublex-expects-0.7.1-r1.ebuild')
-rw-r--r--dev-python/doublex-expects/doublex-expects-0.7.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/doublex-expects/doublex-expects-0.7.1-r1.ebuild b/dev-python/doublex-expects/doublex-expects-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..cf9fba83fe49
--- /dev/null
+++ b/dev-python/doublex-expects/doublex-expects-0.7.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Expects matchers for Doublex test doubles assertions"
+HOMEPAGE="
+ https://github.com/jaimegildesagredo/doublex-expects/
+ https://pypi.org/project/doublex-expects/
+"
+SRC_URI="
+ https://github.com/jaimegildesagredo/doublex-expects/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/doublex[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.8.0_rc1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mamba[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ mamba || die "Tests failed under ${EPYTHON}"
+}