summaryrefslogtreecommitdiff
path: root/dev-python/docutils
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/docutils')
-rw-r--r--dev-python/docutils/Manifest2
-rw-r--r--dev-python/docutils/docutils-0.21.2.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/docutils/Manifest b/dev-python/docutils/Manifest
index 43d7be1cff3e..ca8936024b22 100644
--- a/dev-python/docutils/Manifest
+++ b/dev-python/docutils/Manifest
@@ -3,7 +3,9 @@ AUX docutils-0.21.1-test.patch 1622 BLAKE2B 53f238f048a8251fc50839a6f69faf1c758a
DIST docutils-0.19.tar.gz 2056383 BLAKE2B 9983a905642de4e81ca118578671b503ddfda4bef1afcc0524de40543e1f9617fd8d768ef467da49d2f01076683400bad6a0fe15f6b5a3a1e202c42b2e34ab1b SHA512 fb904a899f2b6f3c07c5079577bd7c52a3182cb85f6a4149391e523498df15bfa317f0c04095b890beeb3f89c2b444875a2a609d880ac4d7fbc3125e46b37ea5
DIST docutils-0.20.1.tar.gz 2058365 BLAKE2B 73fb8302599ffe57b0840c898b0b2e3ccd39ff9ea6eec2b5d345d02c950e1a8357bd821e62733b0484e82bc30e71d30fab381390b0edaef4375b02bcd9eeeb40 SHA512 a0ddca315d03677003036d6a8052ac96fbd3fcc4508564938ea684d79bedb4d322d83449c7b26e55b19b0aadd6e46ca9ac409bb16279a20f06c70e9c15ef5eb0
DIST docutils-0.21.1.tar.gz 2201080 BLAKE2B a89792a69a7faa0eda7b2470e5e3a3d3cf8250a3577553a8f8f8d3d86d2693394e97dca6c75c1b4815748d2ce126ccd3f71dead5763ec8b70aee7be183165473 SHA512 2816fe074b12d7f15fb6730339f3af5f459f50af0cd2a4922194887f48bfd9931c2f2054a17a5418585b586502b96e05ed18600d31c523084537dc72707ab0ee
+DIST docutils-0.21.2.tar.gz 2204444 BLAKE2B 727c2f97fc5835a0ffa62e38ea85af366cd89ad1eaec0b8af8b1f3b12e6cddfddb65161ba34f9109952d37ba2cf8985f3c3b6905ebb2ac1c9a984cce3fb4d170 SHA512 7fafa331f5687448e80d299c20cdccc4b49819fa471b5f586bf0ab18c694ba43a70f58e7c76b0a70a16267585548389214e11a4998ad7fdc19a27f0f7644539c
EBUILD docutils-0.19.ebuild 1729 BLAKE2B 83518b007ed7f6fe5491ad883c6272ea93ee91a177271bb791f63cda6d5b7048d5b8981a734307f8926e41ffdde6c5bb328b1edc41ade6f2e543a5cb9b65c851 SHA512 120702a6a0d4d495c4f9367e11b6b8190352c007ffa8ce767a9f5284bcd366e462dc7e19427e208b1fa98418785de13d17b9bbe1530091cf7a6307611e0a9573
EBUILD docutils-0.20.1-r1.ebuild 1868 BLAKE2B 6816507f5f0519235d7d6f433db171b30d29481ae9d40e36f401e968bedead22910de39189712703c8184fbb1c3997174d25417dfc9d168566bdf37da8b527dd SHA512 de3edcd25ec0e2e812e43bcc12b871b5737bc65bcab05230d9bdf44bc010f6c83df99e4fedbf4e8d737e9d7fd45ed527975176fc641b44107a189627ecc585db
EBUILD docutils-0.21.1.ebuild 2028 BLAKE2B 13a91d4500803367bfd6768ea2a02e7be2a5b442f41eb4d867dc25239f3a0c7da5e5e1725183e7b1a58037350ce8ac3840aa870e3584fcd6e8465908389352ab SHA512 63c3aa8775c39a7c470c2e9fb1246238335aa45aa656979b5ba927641274693c0ef3475162c46204fa0098ba3a0f0d22f5acb8ebc1af98766debe46f904830c5
+EBUILD docutils-0.21.2.ebuild 1907 BLAKE2B 896dbe4787d4a1e48ee0116eae08f57b7adefcd169d8a65c63745b3888723c9bf97ca4ce6a2a693020fb9a878038bb553750756634f0b722d3d7cd6a6ce0255f SHA512 e8b100cc185e7e831f16322d81c05cc618087f5bc3336e60b2578911f406809a74b8fd45eaa3659b56dd1e4f80e0e4ecf01f8a0c4bec4ef07789322fd02139f1
MISC metadata.xml 389 BLAKE2B b586fccb92f88e7f2ee68879bb919298953da9eb629fc1042f5f35b316b59ffcc614f23135fe1ab4af8ba9646bcbc33f194ac74af795094e20d288817b5e227b SHA512 ac8975a27694a2a0efd07c944a769f1a210bbf4a1550f92f0ead3ac2dc9ffb4d82206858f2a8631f751c81fdace88433b9d89f8c3d6af72907e102da5696693f
diff --git a/dev-python/docutils/docutils-0.21.2.ebuild b/dev-python/docutils/docutils-0.21.2.ebuild
new file mode 100644
index 000000000000..73aedd897616
--- /dev/null
+++ b/dev-python/docutils/docutils-0.21.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python Documentation Utilities (reference reStructuredText impl.)"
+HOMEPAGE="
+ https://docutils.sourceforge.io/
+ https://pypi.org/project/docutils/
+"
+
+# GPL-3+ only for emacs/rst.el
+LICENSE="BSD BSD-2 GPL-3+ PSF-2.4 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+python_compile_all() {
+ # Generate html docs from reStructured text sources.
+
+ # Place html4css1.css in base directory to ensure that the generated reference to it is correct.
+ cp docutils/writers/html4css1/html4css1.css . || die
+
+ cd tools || die
+ "${EPYTHON}" buildhtml.py --input-encoding=utf-8 --no-datestamp \
+ --stylesheet-path=../html4css1.css, --traceback ../docs || die
+}
+
+src_test() {
+ cd test || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" alltests.py -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Install tools.
+ python_doscript tools/buildhtml.py
+}
+
+install_txt_doc() {
+ local doc="${1}"
+ local dir="txt/$(dirname ${doc})"
+ docinto "${dir}"
+ dodoc "${doc}"
+}
+
+python_install_all() {
+ local DOCS=( *.txt )
+ local HTML_DOCS=( docs tools docutils/writers/html4css1/html4css1.css )
+
+ distutils-r1_python_install_all
+
+ local doc
+ while IFS= read -r -d '' doc; do
+ install_txt_doc "${doc}"
+ done < <(find docs tools -name '*.txt' -print0)
+}
+
+pkg_postinst() {
+ optfeature \
+ "auto-detecting the image dimensions when using the 'scale' option" \
+ dev-python/pillow
+}