summaryrefslogtreecommitdiff
path: root/dev-python/docopt/docopt-0.6.2-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/docopt/docopt-0.6.2-r4.ebuild')
-rw-r--r--dev-python/docopt/docopt-0.6.2-r4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/docopt/docopt-0.6.2-r4.ebuild b/dev-python/docopt/docopt-0.6.2-r4.ebuild
new file mode 100644
index 000000000000..eda052636089
--- /dev/null
+++ b/dev-python/docopt/docopt-0.6.2-r4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic argument parser, that will make you smile"
+HOMEPAGE="https://pypi.org/project/docopt/ https://github.com/docopt/docopt"
+SRC_URI="https://github.com/docopt/docopt/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.2-pytest_node_from_parent.patch
+)
+
+distutils_enable_tests pytest