summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest4
-rw-r--r--dev-python/dnspython/dnspython-2.2.0.ebuild46
-rw-r--r--dev-python/dnspython/dnspython-2.2.1.ebuild2
3 files changed, 2 insertions, 50 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index cc959afbb764..214a866bbe45 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,5 +1,3 @@
-DIST dnspython-2.2.0.tar.gz 303844 BLAKE2B 5a99a06d1c7e8f29e44ddc99fed11d772d83d962d7abde61befb3189c6faa2796b239e9c0ec05a453360986ff4bbbcea929f62017eb3bab2bafa517ae4c02a3b SHA512 0a93bde1ca1081c92b9fb5a02644c4920813f2d0dbe4de1dae736262d53afe41327f3fdd38a10f74ec78f54dd7c7570e37d0adb2b21ab18f9b5cc099fcc6bb85
DIST dnspython-2.2.1.tar.gz 304861 BLAKE2B e6446b91579c6ec0a7266a354ceb58e2f881b55b7376648770ebc2c6104fd815214497516d305b75802e9211703d47a70d66745d872a43afb72f41e55a617652 SHA512 ec545468f604d6131f07259ca154c4f71d445d12c336ac1da0d2f025d6478ada76320a7235119312fed85da071ef309d2531e541d3c2340a50deaf3f4dd7b4eb
-EBUILD dnspython-2.2.0.ebuild 1064 BLAKE2B 320840fb04982e6fc6f6754110e4363d17959a3c4f4f94447d08098b3a363742166144eff1f84e529174059ea207fb651e40673479e30979072e30a928e6b738 SHA512 0916652f9648b66b0fc5511d5bb5dc79f6aae09f376300d3cdfdfb0b41b7a4d0002f3ad7f09925dfe7700ab33d4d0fa1312071a10ca181ffbe63289cdda99e53
-EBUILD dnspython-2.2.1.ebuild 997 BLAKE2B 0a2d451c67f37867c69059390df2443fd4b8ff801c10c4b2ef223722f889180cd74072e5dc142dd62fb9c4f2e3c82e9168eb9f017046eb4bfcc13e8f091e32c4 SHA512 126856a2e64cdd1fb130c1e4c37c1cc0bc4c4a68618f47dab69bd54027943f7eb55ff369a62b50988fede6e07f0638203c6ad4b1a660f1e5a4d136bf5f007f35
+EBUILD dnspython-2.2.1.ebuild 995 BLAKE2B 78f8d8c154c424929eaba3c05aed3d7a829fec4430365fc5d4995c6821b0611f8d56aa4b6be8d45dd07191e543e7f600c4bde49e812d4efb147c6cdab4bfa0a5 SHA512 995e0c4d429f966d85955d936ba25c4785bd2cd7a0b98edab6027c6a6b1ae4361d6bb5b223593143100ed007dc68908c7a52e8bbabae53680c6bcd1d27a32912
MISC metadata.xml 1483 BLAKE2B c8506d4cb41157307b98f6976d05f6a504a89c3c0924e5135e060018bcd401589b4fbd932b1c61eb34d2823168170281fcee75f8fedda4053207b3844fae336d SHA512 e2b0132864d9a338193e9eed11e85981e48825c194fc35d8e17f9a72b19e04368140556c37a37061059451aaf1c6143030a54f43fb65ab734d2e9636e7e641d3
diff --git a/dev-python/dnspython/dnspython-2.2.0.ebuild b/dev-python/dnspython/dnspython-2.2.0.ebuild
deleted file mode 100644
index 97d64d01ead6..000000000000
--- a/dev-python/dnspython/dnspython-2.2.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="DNS toolkit for Python"
-HOMEPAGE="https://www.dnspython.org/
- https://pypi.org/project/dnspython/"
-SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="examples"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- <dev-python/idna-4.0[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/network_avail/s:True:False:' \
- tests/*.py || die
- distutils-r1_src_prepare
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- epytest -s
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/dnspython/dnspython-2.2.1.ebuild b/dev-python/dnspython/dnspython-2.2.1.ebuild
index 10b72b9da4d7..0d1add912261 100644
--- a/dev-python/dnspython/dnspython-2.2.1.ebuild
+++ b/dev-python/dnspython/dnspython-2.2.1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="ISC"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
IUSE="examples"
RDEPEND="